Errors in Attendance Import to CASES

Errors in Attendance Import to CASES

Overview 

When importing attendance data into CASES, if the date does not match CASES expectations you may receive Errors and/or Warnings at the end of the import process.

  • Warning = Erroneous data detected, but import still completed.
  • Error = Erroneous data detected, import aborted.

You may be able to ignore Warnings but it is advised to correct the data before proceeding. Errors must be fixed in order to successfully import attendance data.

Compass imports student data from CASES, either via a manual General Import or the overnight automated sync via Compasslink. When an existing student is no longer in the CASES export, Compass end-dates this student in all of the enrolments in the classes/activities they are in, this effectively stops the collection of attendance data for the student.


Causes

There are two common causes of this issue:

Situation A

The student is not exited within Compass on their actual exit date, as the school has taken some time to export Student data to Compass. This causes Compass to collect attendance data after the student's CASES exit date. When the attendance data is imported back into CASES using the Compass Attendance Export report a warning is presented in the Warning Report.

Situation B

A Student who did not attend the school, but was in CASES/Compass and has had attendance data collected. When this data is imported to CASES an error is presented.

In both situations the resolution is effectively the same, the extraneous or erroneous data from Compass needs to be removed then re-export the attendance data to CASES.


Resolution

First, find the student within Compass in an 'Advanced Search'. As the student's status has been changed from 'Active' to 'Left' in CASES, they will not appear in the standard search. Enter the student's name or Student ID in the search box and click on 'Show more results'. The student's name will show in the Advanced Search results. Click on the name to navigate to the student's profile and then click on the Attendance tab.

You will be able to determine clearly from the student's Attendance Summary tab whether attendance data exists for the student after their CASES exit date. For example, if James is appearing on the CASES Warning Report and his Exit date is recorded in CASES as 5th June, you can check his Attendance summary page on Compass to see that there is attendance data recorded after the Exit date:



Correct the enrolment dates for all the student's class enrolments by setting their Finish Date to match the Exit date on CASES. Go to the Attendance > Enrolments tab on the student's profile page. Then tick the box beside the class names to select them and click 'Selected Enrolments'. From the drop down menu, select 'Set Finish Date' and change the enrolment finish date to the exit date recorded in CASES for the student.



Alternatively, you can use the pencil icon beside the class name to edit the enrolment start and finish dates/times for individual classes.




For a Student in Situation B the process is similar, but the enrolment is removed instead of adjusted. The 'Delete Enrolments' (red X) button can be used to completely remove the enrolment. This will erase all attendance data for the student in question.

Once all extraneous / erroneous Attendance data has been removed, re-export the Attendance data from Compass and import in to CASES; all warnings and errors will be resolved when you have completed the actions above.

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